tkinterをpyenv上で使用できるようにしたい

投稿者: Anonymous
sudo apt-get install python3-tk

でシステム標準のPython3でimportはできたものの、pyenv環境(python3.5.2)ではimportできません.

pyenv環境でもtkinterのモジュールをimportする方法を教えてください.
また、matplotlibと併用して使用したいです.

解決

以下の手順で解決したという報告があります

  • まずpyenvの Python をアンインストールする: pyenv uninstall 3.4.2
  • tk-devパッケージをインストールする: sudo apt install tk-dev
  • pyenvlの Python を再インストールする: pyenv install 3.4.2

少し情報が古いかもしれませんが、現在のバージョンで試してみてはいかがでしょうか。


(個人的には通常用途でpyenvは必要ないと思っています)

回答者: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *