Nokogiriのエラーについて

投稿者: Anonymous

DBの作成と最新状態へ移行すために、
下記のコマンドを、実行しました。

bundle exec rake db:create
bundle exec rake db:migrate
bundle exec rake db:seed
bundle exec rails g spree:install
bundle exec rake spree_sample:load

その結果、

Nokogiri was built against LibXML version 2.9.7, but has dynamically loaded 2.9.4

というエラーが出てきます。
修正方法がわかりません。

解決

Nokogiri was built against LibXML version 2.9.7, but has dynamically loaded 2.9.4

を訳すと

起動した Nokogiri は バージョン 2.9.7 の LibXMLライブラリを使うように作られていますが、バージョン 2.9.4のLibXMLが読み込まれました。(「違うLibXMLだと正しく動くかどうかわかんないから、Nokogiriの起動をあきらめざるを得ませんでした」という意味)

という感じです。

バージョン 2.9.7 の LibXML をインストールして、LibXMLといえばバージョン 2.9.7 の LibXMLが読み込まれるようにすれば、解決すると思われます。

まずは、システムに組み込まれているLibXMLのバージョンを確認しましょう。

回答者: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *