amazon linux でphp-pecl-memcachedをインストールできない

投稿者: Anonymous
# yum install php-pecl-memcache
Loaded plugins: priorities, update-motd, upgrade-helper
572 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-memcache.x86_64 0:3.0.8-1.9.amzn1 will be installed
--> Processing Dependency: php(api) = 20090626-x86-64 for package: php-pecl-memcache-3.0.8-1.9.amzn1.x86_64
--> Processing Dependency: php(zend-abi) = 20090626-x86-64 for package:    php-pecl-memcache-3.0.8-1.9.amzn1.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.29-1.8.amzn1 will be installed
--> Processing Conflict: php56-common-5.6.30-1.133.amzn1.x86_64 conflicts php-common < 5.5.22-1.98
--> Processing Conflict: php55-common-5.5.38-2.119.amzn1.x86_64 conflicts php-common < 5.5.38-2.119.amzn1
--> Finished Dependency Resolution
Error: php56-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
Error: php55-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


インストールしようとしているパッケージ名は php-pecl-memcache, php-pecl-memcached のどちらでしょうか?

どちらのパッケージも、依存関係により php-common-5.3.29-1.8.amzn1 を必要としますが、既にインストールされている php56-common-5.6.30-1.133.amzn1.x86_64, php55-common-5.5.38-2.119.amzn1.x86_64 と同時には利用できないようです。

現在利用している php のバージョンに合わせて、

回答者: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *