Xcode y error “ld: library not found for -lPods-FriendlyChatObjC” con CocoaPod

publicado por: Anonymous

Estoy siguiendo un ejercicio de un CodeLab de Google sobre Firebase con Objective C que esta publicado en GitHub, y después de bajar el proyecto, instalar Cocoa y los pod update obtengo el siguiente error cuando abro por primera vez el proyecto con el Xcode:

ld: library not found for -lPods-FriendlyChatObjC
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Adjunto la imagen:

introducir la descripción de la imagen aquí

Ya hice clean y rebuild del proyecto, pero el error se mantiene. ¿Alguna sugerencia?

solución

¿Que archivo estás abriendo en Xcode?

Una vez que has instalado los pods con:

pod install

se genera un archivo NombreDelProyecto.xcworkspace, el cual contiene tu proyecto (NombreDelProyecto.xcproject) y todos los pods de los que depende tu proyecto.
Debes de abrir dicho ‘workspace’ y compilar. 😉

Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *