No me funciona video en Bootstrap 4

publicado por: Anonymous

Un gran saludo:

He tenido una dificultad, ya que este vídeo que inserto me sale la imagen del vídeo pero no se reproduce, lo estoy haciendo con Bootstrap 4 de la siguiente manera, no se ¿por que no se reproduce?

Gracias

_x000D_

_x000D_

<div class="embed-responsive embed-responsive-16by9">_x000D_
    <video class="video"src="imagenes/videos/intro.mp4" autoplay loop/>_x000D_
</div>

_x000D_

_x000D_

_x000D_

solución

Estimado, creo que lo que planteas no tiene errores de sintaxis, a lo mucho la definición de la clase “video” está pegado con la definición del atributo src, pero nada que afecte al funcionamiento de la etiqueta.

Como puedes apreciar en el siguiente extracto, estoy utilizando tu misma estructura HTML (ignora la etiqueta link, es sólo para importar Bootstrap 4), con la única diferencia de que en el src definí la ruta a un vídeo válido para el reproductor.

_x000D_

_x000D_

<link href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0/css/bootstrap.min.css" rel="stylesheet"/>_x000D_
_x000D_
<div class="embed-responsive embed-responsive-16by9">_x000D_
    <video class="video"src="https://www.sample-videos.com/video/mp4/720/big_buck_bunny_720p_20mb.mp4" autoplay loop/>_x000D_
</div>

_x000D_

_x000D_

_x000D_

Haz lo que te sugiere Tegito123:

[…] primero que nada debes ver la compatibilidad de los diferentes formatos de video para cada navegador, aparte de ello que tu source o url del video este bien definido […]

Respondido por: Anonymous

Leave a Reply

Your email address will not be published.