Flutter Error running Gradle:

publicado por: Anonymous

E:UsersJOSHUA ELIOneDriveProyectosCódigoFlutternew_set>flutter run

Using hardware rendering with device Android SDK built for x86. If you get graphics artifacts, consider enabling
software rendering with “–enable-software-rendering”.

Launching lib/main.dart on Android SDK built for x86 in debug mode…

Initializing gradle… 1.1s

Resolving dependencies…

  • Error running Gradle:
    ProcessException: Process “E:UsersJOSHUA ELIOneDriveProyectosCódigoFlutternew_setandroidgradlew.bat” exited
    abnormally:

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘E:UsersJOSHUA ELIOneDriveProyectosCódigoFlutternew_setandroidappbuild.gradle’ line: 24

  • What went wrong:
    A problem occurred evaluating project ‘:app’.

    Failed to apply plugin [id ‘com.android.application’]
    Your project path contains non-ASCII characters. This will most likely cause the build to fail on Windows. Please
    move your project to a different directory. See http://b.android.com/95744 for details. This warning can be disabled
    by adding the line ‘android.overridePathCheck=true’ to gradle.properties file in the project directory.

  • Try:
    Run with –stacktrace option to get the stack trace. Run with –info or –debug option to get more log output. Run with
    –scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 1s
Command: E:UsersJOSHUA ELIOneDriveProyectosCódigoFlutternew_setandroidgradlew.bat app:properties

Please review your Gradle project setup in the android/ folder.


En teoría ya vi varios posts en inglés y no sé qué onda con este error, algunos sugieren que me vaya al repositorio de Flutter, ósea

flutter/packages/flutter_tools/gradle/flutter.gradle

Y lo que entendí, algunos sugieren que cambie

buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'
    }
}

por

buildscript {
    repositories {
        google()
        jcenter()
        maven {
            url 'https://dl.google.com/dl/android/maven2'
        }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.2'
    }
}

Y ya hice el cambio pero no logré ningún cambio, intenté crear una nueva carpte de Flutter create ¿alguna sugerencia?

solución

Resultó ser mucho más simple de lo que imaginé, básicamente sólo resultó en ser un error con los caracteres ASCII, creo que leí mal el mensaje, si alguien tiene este error en específico sólo tiene que cambiar la ruta, cambiando cualquier carpeta como por ejemplo yo que en una carpeta tenía

‘Código’

Y creo que debido a errores del Framework no acepte caracteres como el ‘ó’, de ese modo cambiar a

‘Codigo’

Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *