Failed to resolve: com.android.support:appcompat-v7:27.+ android studio 2.3.3

publicado por: Anonymous

Utilizo android studio 2.3.3

y cada vez que inicio un nuevo proyecto me marca este error
introducir la descripción de la imagen aquí

este es mi archivo granddle Module:App

apply plugin: 'com.android.application'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 27
    buildToolsVersion "27.0.3"
    defaultConfig {
        applicationId "com.example.yahlopee.capteurs"
        minSdkVersion 19
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:appcompat-v7:22.0.0'
    compile 'com.h2database:h2:1.4.186'
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    testCompile 'junit:junit:4.12'
}

y este es el build.gradle project

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()


    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

ya he intentado agregar en allprojects maven, pero ni aun asi funciona, alguien tiene alguna solucion y tampoco puedo cliquear el enlace que parece debajo del error

solución

Estas definiendo:

compileSdkVersion 27
buildToolsVersion "27.0.3"

y

targetSdkVersion 27

pero estas usando Android Studio 2.3.3, el máximo soporte para esta versión es para API level 26, si es que funcionara con Android Studio 2.3.3 incluso implicaría cambiar la versión de Gradle de:

classpath 'com.android.tools.build:gradle:2.3.3'

a:

classpath 'com.android.tools.build:gradle:3.0.1'

Te recomiendo actualices a android 3.0.1 que es la versión estable (Marzo 2018), de esta forma podrás usar la API 27 sin problema :

https://developer.android.com/studio/index.html?hl=es-419

Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *