Error compilando com.google.gms:play-services-ads:9.2.0

publicado por: Anonymous

Actualizando las dependencias en android studio me encuentro con el siguiente error.

Error:Execution failed for task ':app:processDebugGoogleServices'.
> Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/android/android-tools/com.google.gms.google-services/) or updating the version of com.google.android.gms to 9.0.0.

Anteriormente tenia las dependencias de la siguiente forma.

apply plugin: 'com.android.application'


android {
     compileSdkVersion 24
     abuildToolsVersion "23.0.3"

defaultConfig {
    applicationId "com.android.myapp"
    minSdkVersion 15
    targetSdkVersion 24
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'),           'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'

    compile 'com.android.support:appcompat-v7:24.0.0'
    compile 'com.android.support:design:24.0.0'
    compile 'com.android.support:support-v4:24.0.0'
    compile 'com.android.support:cardview-v7:24.0.0'
    compile 'com.android.support:design:24.0.0'
    compile 'com.android.support:palette-v7:24.0.0'
    compile 'com.android.support:mediarouter-v7:24.0.0'

    compile 'com.google.firebase:firebase-ads:9.0.0'
    compile 'com.google.firebase:firebase-crash:9.0.0'
    compile 'com.google.firebase:firebase-analytics:9.0.0'

    compile 'com.google.android.gms:play-services-ads:9.0.0'

}

apply plugin: 'com.google.gms.google-services'

El error me sale al cambiar la linea

compile 'com.google.android.gms:play-services-ads:9.0.0'

a

compile 'com.google.android.gms:play-services-ads:9.2.0'

solución

Solucionado, había que actualizar también los plugins de firebase a la versión 9.2.0

compile 'com.google.firebase:firebase-ads:9.2.0'
compile 'com.google.firebase:firebase-crash:9.2.0'
compile 'com.google.firebase:firebase-analytics:9.2.0'
Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *