Error al instalar apk con Android Studio : DELETE_FAILED_INTERNAL_ERROR

publicado por: Anonymous

he creado una app de un feed de un blog y hasta ahí no me da ningún error.
A la hora de probarlo compila bien, pero al instalarlo me aparece esta ventana:
introducir la descripción de la imagen aquí
Aun teniendo la app desinstalada, le de a ok o cancel, abajo a la izquierda sale un cartel que dice:
Session ‘app’: Error Installing APK.
La palabra app es un vinculo que te lleva a la ventana de Run app, en la que aparece lo siguiente:

09/19 13:46:09: Launching app $ adb push
C:UsersPCDesktopFeedCharcuteriaJJEEappbuildoutputsapkapp-debug.apk
/data/local/tmp/feedcharcuteriajamoneseutiquio $ adb shell pm install
-r “/data/local/tmp/feedcharcuteriajamoneseutiquio” pkg: /data/local/tmp/feedcharcuteriajamoneseutiquio Failure
[INSTALL_FAILED_INVALID_APK]

$ adb shell pm uninstall feedcharcuteriajamoneseutiquio
DELETE_FAILED_INTERNAL_ERROR Error while Installing APK

solución

Si alguien sigue teniendo este problema, les digo la solución que se me ocurrió (luego de horas de búsqueda sin éxito). Como Android Studio intenta instalar un APK para correr el emulador, se me ocurrió eliminar el APK existente del proyecto.

Fui a la carpeta del proyecto, donde está localizado el archivo “app-debug.apk”; (en mi caso “NOMBRE_DEL_PROYECTOappbuildoutputsapkdebug”), y para no perder ningún dato (ya que soy nueva en esto), modifiqué el archivo “app-debug.apk” por “app-debug.apk.txt” (de forma que Android Studio no lo reconozca e intente instalar nuevamente el APK). Luego cerré el emulador, y le di “Run” de nuevo. A la primera no me funcionó del todo bien, ya que estaba instalando el APK mientras corría el emulador, por lo cual tuve que cerrar el emulador de nuevo, y correrlo otra vez. Ahora está funcionando sin problemas!

Estoy trabajando con la siguiente configuración:
Mi AVD es un Nexus 4 corriendo Android Oreo (API 27), cuya configuración gráfica es “Software – GLES 2.0” (por defecto, al instalar AS viene como “Automática”, y eso genera otros problemas al correr la app).
Además estoy en un Windows 10, utilizando Android Studio 3.1.4.

Espero a alguien le sea de ayuda!

PD: Este es mi primer post 🙂

Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *