¿Cómo convierto de un tipo de dato a otro en pseInt?

publicado por: Anonymous

Estoy lidiando con una limitación técnica al tratar de hacer un casting de tipo de dato Entero a Real y viceversa.

Estoy usando el perfil CBTis45 que como saben es de poco detalle en cuanto a las palabras reservadas lo que permite un pseudocódigo más legible y usa una sintaxis flexible.

Quisiera seguir usando ese mismo perfil.

Hasta el momento he intentado esto:

Proceso redondeaAdosDecimales
    Escribir 'escribe un número con decimales';
    Definir numero Como Real;
    Leer numero;
    Definir numeroEntero Como Entero;
    numeroEntero <- (Entero)numero*100;
    Definir numeroRedondeado Como Real;
    numeroRedondeado <- (Real)numeroEntero/100.0;
    Escribir 'Tu número redondeado es ',numeroRedondeado;
FinProceso

solución

Puedes usar las funciones trunc y redon para truncar y redondear respectivamente con la conversión de tipos realizada internamente.

Por otro lado falta mostrar o escribir la variable numeroEntero.
Me faltaría saber que resultado pretendes obtener, pero según te entiendo sería algo así.
Tu pseudocódigo quedaría así:

Proceso redondeaAdosDecimales
    Escribir 'Escribe un número con decimales';
    Definir numero Como Real;
    Leer numero;
    Definir numeroEntero Como Entero;
    numeroEntero <- trunc(numero);
    Definir numeroRedondeado Como Entero;
    numeroRedondeado <- redon(numero);
    Escribir 'Tu número truncado es ',numeroEntero;
    Escribir 'Tu número redondeado es ',numeroRedondeado;
FinProceso
Respondido por: Anonymous

Leave a Reply

Your email address will not be published. Required fields are marked *